Cannot login to admin page (manage)

This looks like the correct behavior. What exactly is your issue or question?

The problem is I can’t enter the admin page even though I use the correct password.

That page is the admin page. Are you saying the page doesn’t load?


The admin page can be loaded, but when I open it the superuser password will be asked. My authentication was not accepted despite using the correct password.

Do you see anything on the logs or in the browser console? Also I’m assuming you are 100% sure you are entering the correct password :smiley:

I’d try resetting my password following the forgot password flow and see if that helps.

If I use the forgotten password flow, I might not be able to receive notifications because the smtp is off :smiley:

In the browser console I found this:

You can try creating a new super user with sentry createuser --superuser and log in with that or use sentry shell, get your User model and then change its password?

I have tried to create a new account and give superuser access, but it’s the same, my authentication has been refused to open the page /manage even though using the correct password.

Just now smtp on my sentry server has been activated again, and I tried to forget the password method, after I set the new password again, my authentication is still rejected.

Btw, can this be changed to the root url sentry via the postgres database or from other places? Maybe there is a problem there.

for on-premise, you can change the URL in the yml file and run the again to have the docker image updated to the new URL.

1 Like

@sibunglon - oh, if the URL redirection is not correct, it may fail to set certain cookies properly which may cause this issue. It may also be related to any HTTPS config if you have that set up.

As @liangrong mentioned, you can change the system.url-prefix value in config.yaml file and rebuild your Docker image to change you root URL and see if that fixes the issue.

@BYK @liangrong Can you help me, I’m using this sentry docker >

Had same issue. To solve it:

  • Connect to PostgreSQL database
  • Table: auth_user
  • Find you user line, and set is_superuser to true

@forzagreen I have tried it but it hasn’t worked.

I have a same problem,how do you solve it?

I have not solved it, maybe you can try advice from @forzagreen.

My browser’s erro information is same with you,I think what cookie cant’s pass to backend end.But I don’t how to solve it.

@BYK Can you help us?

Hi @sibunglon,I change sentry verion from 9.1.2 to 9.0.0.The problem was solved.

Hi @linux0x5c, nice, do you reinstall sentry or use other techniques?

I use helm chart,I just change image tag.