Cannot receive events via https

I have successfully installed Sentry On-Premise via docker (docker-compose) following the instructions in https://github.com/getsentry/onpremise. I also installed NGINX as a reverse proxy and I can successfully access Sentry Web Interface via https. I am struggling to send events to Sentry via https. I have added to sentry.config.py

SECURE_PROXY_SSL_HEADER = (‘HTTP_X_FORWARDED_PROTO’, ‘https’)
SESSION_COOKIE_SECURE = True
CSRF_COOKIE_SECURE = True
SOCIAL_AUTH_REDIRECT_IS_HTTPS = True

and
SENTRY_USE_SSL = 1

but I cannot receive events via https.
When accessing from the web UI in the /manage/status/environment/ section it reports that SECURE_PROXY_SSL_HEADER is set to “None” which seems to me that the config hasn’t been applied. I am quite new to Sentry so I am probably missing something. Any help would be really appreciated.

If you’re able to access the web UI over https, there’s no difference in accepting events over https. It all goes through the same thing. Can you provide more information on what’s wrong when you try?

I couldn’t receive the events in the back end. Today I can normally receive the events via https. The only difference today is that I edited the Root URL (switched to https) in order to have correct internal links. Maybe I was missing something else yesterday. Thank you for your response @matt.

Hi geoandri,

I am having troubles setting up sentry on premise with https, i am using docker-compose too, however, can you please let me know, i need to remove the if statement and just keep the settings here

if env('SENTRY_USE_SSL', False): # do i need to remove this line 
SECURE_PROXY_SSL_HEADER = ('HTTP_X_FORWARDED_PROTO', 'https')
SESSION_COOKIE_SECURE = True
CSRF_COOKIE_SECURE = True
SOCIAL_AUTH_REDIRECT_IS_HTTPS = True

also, where do i specify SENTRY_USE_SSL = 1, do i specify this in the docker compose file?

hi, @AksharJ. had you resolved it?