Error while updating containerized self-hosted 9.1.2 to 22.3.0

Hi guys,

I’m trying to update dockerized self-hosted sentry from version 9.1.2 to the lastest (22.3.0), but for now without success.

What I’ve made:

  1. Built a new machine for the new version
  2. Installed it by running ./
  3. Started the new install
  4. Dropped the new database and imported the backup made from the old installation into the new postgres container
  5. Tried to run - no success

Now I’ve cleared all the other containers in the new install excluding the postgres’s one (which currently have the old database imported there) and tried to run - no success again and I’m receiving the following errors:

Creating sentry-self-hosted_snuba-outcomes-consumer_1                  ... done
Creating sentry-self-hosted_snuba-replacer_1                           ... done
Creating sentry-self-hosted_snuba-transactions-consumer_1              ... done
Creating sentry-self-hosted_snuba-consumer_1                           ... done
Creating sentry-self-hosted_snuba-subscription-consumer-transactions_1 ... done
Creating sentry-self-hosted_snuba-api_1                                ... done
Creating sentry-self-hosted_snuba-sessions-consumer_1                  ... done
Creating sentry-self-hosted_web_run                                    ... 
Creating sentry-self-hosted_web_run                                    ... done
Updating certificates in /etc/ssl/certs...
0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d...
Installing additional dependencies...
WARNING: Running pip as the 'root' user can result in broken permissions and conflicting behaviour with the system package manager. It is recommended to use a virtual environment instead:                                                                                                                                                                                                                     

11:49:59 [WARNING] sentry.utils.geo: Error opening GeoIP database: /geoip/GeoLite2-City.mmdb
11:49:59 [WARNING] sentry.utils.geo: Error opening GeoIP database in Rust: /geoip/GeoLite2-City.mmdb
/usr/local/lib/python3.8/site-packages/sentry/runner/ DeprecatedSettingWarning: The SENTRY_URL_PREFIX setting is deprecated. Please use SENTRY_OPTIONS['system.url-prefix'] instead.
  warnings.warn(DeprecatedSettingWarning(old, "SENTRY_OPTIONS['%s']" % new))
11:50:04 [INFO] sentry.plugins.github: apps-not-configured
Running migrations for default
Operations to perform:
  Apply all migrations: admin, auth, contenttypes, nodestore, sentry, sessions, sites, social_auth
Running migrations:
  Applying sentry.0001_squashed_0200_release_indices...Traceback (most recent call last):
  File "/usr/local/lib/python3.8/site-packages/sentry/db/postgres/", line 91, in inner
    return func(self, sql, *args, **kwargs)
  File "/usr/local/lib/python3.8/site-packages/sentry/db/postgres/", line 87, in execute
    return self.cursor.execute(sql)
psycopg2.errors.DuplicateTable: relation "auth_user" already exists

Can somebody give me advise how this should be done in the best way?

Thanks in advance.