./install.sh error

i am new to sentry, cloned the repo and install it by running install.sh on my ubuntu but hit error (paste below), anyone know what problem?

Setting up database…
./install.sh: line 271: [: ==: unary operator expected
–no-ansi option is deprecated and will be removed in future versions.
Creating sentry_onpremise_postgres_1 …
Creating sentry_onpremise_smtp_1 …
Creating sentry_onpremise_memcached_1 …
Creating sentry_onpremise_symbolicator_1 …
Creating sentry_onpremise_snuba-consumer_1 …
Creating sentry_onpremise_snuba-transactions-consumer_1 …
Creating sentry_onpremise_snuba-replacer_1 …
Creating sentry_onpremise_snuba-outcomes-consumer_1 …
Creating sentry_onpremise_snuba-api_1 …
Creating sentry_onpremise_snuba-sessions-consumer_1 …
Creating sentry_onpremise_smtp_1 … done
Creating sentry_onpremise_snuba-consumer_1 … done
Creating sentry_onpremise_postgres_1 … done
Creating sentry_onpremise_snuba-transactions-consumer_1 … done
Creating sentry_onpremise_memcached_1 … done
Creating sentry_onpremise_snuba-api_1 … done
Creating sentry_onpremise_symbolicator_1 … done
Creating sentry_onpremise_snuba-outcomes-consumer_1 … done
Creating sentry_onpremise_snuba-sessions-consumer_1 … done
Creating sentry_onpremise_snuba-replacer_1 … done
Creating sentry_onpremise_web_run …
Creating sentry_onpremise_web_run … done
e[31m!! Configuration error: ConfigurationError(“error: argument for ‘s’ must be a bytes object”,)e[0m
1
An error occurred, caught SIGERR on line 280
Cleaning up…

Can you share the full logs and which version of the repo you are cloning?

Hi, the repo should be the latest version

full logs

The problem is, that is not our repo :slight_smile:

So you’d need to file this issue on that repo. Seems like they based their repo off an older version of our onpremise repo.

oic, thanks!

1 Like