Making Javascript Source Maps work


I have problems understanding how source maps should be uploaded so that they work. I always get the “Source code was not found for X” error for JS events.

I don’t know what’s wrong (is it my source map ? is it the name I gave it ? is it something else ?) and I don’t understand how I can troubleshoot it. I’ve tried uploading the maps with several distinct names (using the tilde and not using it, using paths or removing them, using the query string or not…)

My file is
And I’ve tried uploading both the JS file and the map file (containing the inlined sources and minified with UglifyJS and Grunt)

How can I understand what’s wrong ?
Thank you for any help or if you can help me get on the right track to find a solution. :slight_smile:

Robin Nicollet,
CTO of

While I’m not 100% sure, it’s possible this is related to another issue reported on the forums:

I’m sorry to dig this up but it’s still not working, although I’ve been through your entire source map troubleshooting page ( ). The annoying thing is Sentry does not work and ask me to pay for more events, and I can’t get source maps to work after having spent more than 2 days on it, and of course if there are no new events recorded I can’t check if it works, as you specify that releases will work only on new events.

I’d be happy to become a customer but I don’t see how I’m ever going to be one if I can’t make the product work.

To sum up what I did

  • I uploaded source maps using cURL and different prefixes (using the ~ or not)
  • I uploaded source maps using the sentry-cli (three times, one with the --url-prefix to my CDN, one with the --url-prefix being my code folder, and one without --url-prefix, always with the --validate flag which gave me only one error - a file that is not present in any minified script (no sourcemap ref) )
  • I checked my sourcemaps at which told me they’re configured properly
  • I checked my sourcemaps in Chrome, which has no problem reading them
  • I checked my sourcemaps using the npm source-map package and the sample script you give. disclaimer: it works locally
  • none of my files are more than 40MB

Sorry for my tone but I hope you’ll understand just how frustrating this is.

@hilnius If you post more information into our actual support, I’d be happy to actually look at your events and check out what you’re doing wrong. Unfortunately, without seeing your account, we can only speculate and provide generic information.

@matt I’d like to but I don’t have access to your support, as I’m trying to make the free version work (and if I understand correctly, accounts on the free version do not have access to support)

Email into and I will help you. You should have access to support normally during free trial, but I assume you’re past that period now, but it’s fine. I’ll just check your account.