O1.ingest appears in DSN settings after upgrading from v9 to 20

Hi Sentry folks,

I having a weird issue that I cannot find in any configuration.
We migrated Sentry from v9 to v20 (a big step) everything seems to work but the workers in the background trying to reach o1.ingest.HOSTNAME and in the DSN configuration page on a project there is also o1.ingest.HOSTNAME appear somehow. And cannot find what kind of configuration causes this problem. Because I assume that the address just needs to be HOSTNAME without the “o1.ingest” part?

Kind regards,

The featureflag that enables this behavior is opt-in. Did you per chance enable all features in your sentry.conf.py?

@untitaker I didn’t I’m using the helm chart of Sentry, and I only added in the sentryConfPy some github-app settings. What feature flag gives this behavior then? or what can I put in the configuration to disable this or override the feature flags?

Please take this up with the helm chart folks. You have this feature enabled which is not a good idea in onprem: https://github.com/getsentry/sentry/blob/1558974d0a6270fe5683f6ff648ff66813ce3810/src/sentry/conf/server.py#L889-L891