Onpremise integration with github issue

when I am trying to integrate self hosted sentry with github, i am getting this error

We’d need to see the logs from your web container to be able to offer any suggestions.

Sorry for late reply.

This is the log file.

These are installation logs, I meant the logs from your web container when you encounter this error. See https://develop.sentry.dev/self-hosted/troubleshooting/#general

I found those which I mentioned above, are those the logs which you asked?

Nope, please read the document I referred carefully. If that doesn’t help you find the logs, you might be better off using sentry.io instead of maintaining a self-hosted version.

Sir, actually I am fresher, new to this. My team lead has given me this work, develop sentry to our company by taking the source code from github. I even don’t have an idea on which source code I have to take. As for now I have taken onpremise code.

Can you please guide me on this?

@reddeiah - you are on the right track. GitHub - getsentry/sentry: Sentry is cross-platform application monitoring, with a focus on error reporting. is the main Python package but since Sentry needs multiple services to run now, we have created the GitHub - getsentry/onpremise: Sentry On-Premise setup repository to provide a simple way to get it up and running. That said it still requires some knowledge of Docker, docker-compose, and overall, some operational knowledge/experience.

What I’m asking was the output of docker-compose logs web command right after you get that error.

That said know that we won’t be able to assist you much further to get this into a production stage.

when I run that command in ubuntu cmd, it showed this eroor

I made some changes in source code and ran it. then, in sentry when I click github integration
Github marketplace window opened. So, what to do now?

You need to run this command inside the directory where you have the onpremise repo checked out.

Dear @reddeiah, this is not a forum where someone walks you through the steps one by one. This information is available on GitHub | Sentry Documentation and https://develop.sentry.dev/integrations/github/

Please read all the docs, try to troubleshoot these on your own spending some time before asking here on the forums.

Okay. I will go through the document.

These are the logs

I don’t see any issues from your nginx and web logs.

I have gone through the document, but I am not getting what to do in after it showed github marketplace window.

can you please tell me?

I tried by changing the code several times. But same error it is showing which I mentioned in the first.

Any solution for this.

  • Do you have your system.url-prefix config set?
  • Did you follow this guide to create your GitHub app under your organization and add its credentials to your config: https://develop.sentry.dev/integrations/github/
  • From which page you are getting to the marketplace page?
  1. yes, I have set system.url-prefix config in confi.yml file.
  2. yes, I followed that guide and have added GitHub app credentials in config.yml file under GitHub integration.
  3. now, its not showing marketplace. In sentry>settings>integrations>GitHUb when i click “add installation” It is showing the github app page which I have created. when I click install button of that app, it is showing this error.