Problem with using sentry on netframework 4.7.2

I am trying to add sentry intergration to an old winforms application that currently uses .net framework 4.7.2

For test purposes the main function only contains following code :

            SentryId id;
            SentryOptions op = new SentryOptions();
            op.Dsn = new Dsn(my dsn goes here);
            op.Debug = true;
            using (var sentry = SentrySdk.Init(op))
            {
                id = SentrySdk.CaptureException(new Exception("testException"));
            }

When I try to run the application I get the following error.

Error: An error occured when capturing the event System.IO.FileNotFoundException: File or assembly System.Runtime.InteropServices.RuntimeInformation, Version=4.0.2.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
or some of its dependencies cannot be loaded. File not found.
Filename: ‘System.Runtime.InteropServices.RuntimeInformation, Version=4.0.2.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a’
target Sentry.Internal.MainSentryEventProcessor.Process(SentryEvent event)
target Sentry.SentryClient.DoSendEvent(SentryEvent event, Scope scope) in file C:\projects\sentry-dotnet\src\Sentry\SentryClient.cs:line 141
target Sentry.SentryClient.CaptureEvent(SentryEvent event, Scope scope) in file C:\projects\sentry-dotnet\src\Sentry\SentryClient.cs:line 88

The stacktrace was partially in finnish and I have translated so it might not be identical on different computer. I have tried creating entirely different application and sentry works fine on that so problem is not in the development environment.

OS: window 10 pro
IDE: Visual Studio Professional 2019 Version 16.5.4

Sounds like System.Runtime.InteropServices.RuntimeInformation is not available.
This assembly is part of .NET Framework 4.7.2 so maybe some binding redirect issue?

Note that the SDK only depends on that if you end up resolving to the .NET 4.5 dependency or .NET Standard 1.5:

By any chance do you depend on the Sentry nuget package from a class library?

Try adding https://www.nuget.org/packages/System.Runtime.InteropServices.RuntimeInformation/ as a dependency to your project directly, see if that resolves the issue.

Finally, as a suggestion, if possible, consider using .NET Core 3.1 on your WinForms app. You can also bundle the runtime and make it a self contained app (won’t need .NET installed on the machine to run). It also packages it to a single executable.

Thanks for the help. Everything works now.
It ended up binding redirect issue.