React install fails with ProjectID error

Fresh Sentry install via Heroku for React project.
Copy pasted as required:

Sentry.init({dsn: "https://***@***.ingest.sentry.io/***"});

Can’t submit exceptions to Sentry, getting back:

{ detail: "event submission rejected with_reason: ProjectId" }

Anyone any idea why it fails out of the box?

Hi there,

I’m having the same issue with a Vue Application.
Also freshly deployed on Heroku.

Did you already find a solution for this?

Regards
Andreas

I would write into support with this as they will be able to tell you why your concrete DSN does not work.

Didn’t find a solution yet.

And I don’t see where I can contact Sentry support, its either look for existing answers or go here… is there a way to contact them directly?

If you’re on a paid plan you should be able to contact support via the UI. Otherwise please DM me to get this sorted out.

Hi

I am on the free plan as I was testing if the solution fits us and got stuck on the first step.

Tried to DM you, but it seems like its not possible on this form. Any email/etc to contact you?

Thanks in advance

Hi both, just to add a “me too” to this.

I have 2 (free) projects, 1 works fine and behaves as expected, my new project (ASP .NET) behaves the same as Boris.

If I take the working DSN and place in in the “new” application, errors report without issue.

With the broken DSN I either get 403 forbidden, or { detail: “event submission rejected with_reason: ProjectId” }

Both applications coming from the same IP/platform

~Okay, everybody who experienced this problem please email me at [redacted]. I encountered this bug myself in 2019 but discarded it as a fluke and could not repro since.~

EDIT: I have enough information, we have a series of bugfixes that should go out in two weeks. The impact right now seems to be that you have to wait one hour before the DSN starts working.

Hi there, i’ve just tried again now, and its working absolutely fine! :slight_smile:

It was a new project that i was trying to post to (ie newly created) and had only been created minutes before attempting to submit errors (although over probably the course of an hour or so it still failed)

I got this error and it was a bad DSN (typo)!