Sentry AD (Active Directory) integration


#1

Hi, I thought I’d kick off a new thread as the most recent one is from about 7 months ago.

Here’s the link to what was apparently solved but with no explanation how.
Most recent AD post.

In order to get AD integrated with sentry, I need to install django-auth-ldap. The problem is when I attempt to do that with pip, it has to upgrade Django to version 1.11 and I’m informed that that version of Django is incompatible with Sentry 9.0 which requires <= 1.7 and I had 1.6.11 installed. It did in fact upgrade Django to 1.11, but now the sentry login page definitely seems to have problems at least when I use firefox. Chrome still seems to get past the login and display the “Welcome to Sentry” page. I’m leaving this wizard to the development team to complete so I have no idea whether it’s actually working.

Anyone have an idea how I get past this apparent version conflict so that sentry and django-auth-ldap are both happy in my Python virtualenv?

The development team requested LDAP integration as there will be a fair number of members accessing Sentry.

I’m thinking maybe a downgrade of a package? I had to downgrade redis-py-cluster from 1.3.6 to 1.3.4 to get Sentry to install.

Thanks.


#2

Downgrading seems to be the solution.

I was thrown off as yolk -V wasn’t working and then googling brought me across a page where people said it isn’t very reliable and often only returns the latest version.

The workaround was: pip install django-auth-ldap==
It throws an error message that shows every available version so I worked my way down to django-auth-ldap 1.2 from 1.7 which is compatible with django 1.6.11 so Sentry should be happy.

Hopefully 1.2 gets the job done for AD integration. I’ll follow up later.