Sentry upgrade from 8.15.0 to 9.1.2 to 10.0.0 is succesfull but later upgrade fails

sentry upgrade from 8.15.0 to 9.1.2 to 10.0.0 is succesfull but later upgrade fails
the error is as follows
sentry upgrade error return sentry_groupedmessage

little bit of a back story my postgres exist on GCP (cloudsql)… any help would be appreciated.

8.15.0 was the pre-docker sentry.

This should help you: https://develop.sentry.dev/self-hosted/releases/#hard-stops

1 Like

i did follow this procedure , but this error

.---- ‘Project’ object has no attribute ‘get_option’ An error occured while trying to migrate the following event: <sentry.eventstore.models.Event object at 0x7ff7ec4cbeb8> .---- ‘Project’ object has no attribute ‘get_option’ An error occured while trying to migrate the following event: <sentry.eventstore.models.Event object at 0x7ff7ed3fa7f0> .---- ‘Project’ object has no attribute ‘get_option’ An error occured while trying to migrate the following event: <sentry.eventstore.models.Event object at 0x7ff7ec4cbeb8> .---- ‘Project’ object has no attribute ‘get_option’ An error occured while trying to migrate the following event: <sentry.eventstore.models.Event object at 0x7ff7ed3fa7f0> .---- ‘Project’ object has no attribute ‘get_option’ An error occured while trying to migrate the following event: <sentry.eventstore.models.Event object at 0x7ff7ec4cbeb8> .---- ‘Project’ object has no attribute ‘get_option’

this error keeps getting printed over and over again, and is still running… should i wait or does this mean the setup has failed?