Sourcemaps: Remote file took too long to load


It seems that Sentry is unable to download our sourcemap files. That said, the maps are properly referenced in the source files and Chrome Devtools load them just fine. The exact error is

Remote file took too long to load: (15s, Collapse
  "url": "",
  "timeout": 15

That said, this URL works just fine with e.g. Curl.
Any ideas?

1 Like

I’m also interested. We’re throwing the same error (sentry request timeout). I assume sentry is attempting to fetch a sourcemap/js file that’s too large.

We responded by uploading our own sourcemaps via the cli, but still get this error

Our maps are 6 MB in size, I’ll try reducing it to see if it helps.

Seems to do the trick! Disabled sourcemaps for vendor modules, and now the test event shows relevant sourcemaps now.

The new sourcemap size is about 1.5 MB

Related: is there a way to change this timeout if we really must have large sourcemaps or slow servers?

I have had this issue continuously and have given up trying to fix it (though I will look into reducing the size by omitting the vendor modules), though I did once do some digging to see if there was a setting for this and gave up.

1 Like

And does Sentry really have to download sourcemaps for each separate Event? Wouldn’t it make sense to cache them for the given release field?

1 Like

Oh yeah, this for sure - and I’d be happy with a setting to only keep the last 1, 2, 5, 10, whatever release’s worth of auto-downloaded sourcemaps if you’re worried about space.

Realistically, for me, I only need the latest one.

We are having this problem too (large-ish files, about 3mb).

Is there any way to trigger a retry? Most of the time sentry loads our source-maps fine, but I think sometimes when our side in under load, it fails with this error message. I just want to hit a button that says ‘retry source map downloads now’.

1 Like

Did you ever figure out a solution to this? Is there a way to either change the timeout to more than 15s, or maybe a “retry downloading source maps now” button?
I’m also facing this issue, but with no way to make my source maps smaller :frowning:

In general you should not rely on Sentry scraping sourcemaps. It’s unreliable and problematic for versioning.

As part of your build or deploy process you should simply upload the resulting artifacts (and relevant source/sourcemaps) to Sentry using the releases API.

1 Like

Thanks for the response! I will try to integrate the artifacts uploading into our deploy process then.

There is one thing: uploaded source maps as artifacts never match original sources. This way un-minifying process is completely broken and unconfigurable. I don’t know why you ignore this huge issue at Sentry. Spent literally 2 days trying to configure this “feature” and had no success. What’s described in the docs is not working at all. Some parts of the docs just missing, had to go through the github issues and even digged into your source code.
Just a waste of time and money. I would never recommend your tool.

I just went through what’s in the docs to verify the flow and it works. You need to make sure the release name matches and the artifact names too.

I would like to improve the debuggability of this. If you can show me the error you are getting I can see what we can do there.

See my comment here

Also tried this way