System.url-prefix question

hello,
just installed sentry in a server and everything works great…i did run docker-compose before i tweak the config.yml
however, i cannot set the system.url-prefix, every link in the ui is still rendered with the old notation,namely

http://ip:9000

i have these containers

CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
a9226a29e3f0 onpremise_worker “/entrypoint.sh ru…” 2 days ago Up 24 hours 9000/tcp onpremise_worker_1
e19b427e8d3b onpremise_web “/entrypoint.sh ru…” 2 days ago Up 35 minutes 0.0.0.0:9000->9000/tcp onpremise_web_1
76e05f7125e5 onpremise_cron “/entrypoint.sh ru…” 2 days ago Up 24 hours 9000/tcp onpremise_cron_1
008e063992ee onpremise_base “/entrypoint.sh ru…” 2 days ago Up 24 hours 9000/tcp onpremise_base_1
813d6770b12d postgres:9.5 “docker-entrypoint…” 2 days ago Up 24 hours 5432/tcp onpremise_postgres_1
d058b4230d75 tianon/exim4 “entrypoint.sh tin…” 2 days ago Up 24 hours 25/tcp onpremise_smtp_1
d484eda1141d memcached:1.4 “docker-entrypoint…” 2 days ago Up 24 hours 11211/tcp onpremise_memcached_1
61dab8cc4234 redis:3.2-alpine “docker-entrypoint…” 2 days ago Up 24 hours 6379/tcp onpremise_redis_1

i imagined that editing the config.yml file and restarting the onpremise_web_1 container would load the new config, but i guess i am wrong…so the main question is? how to set the system.url-prefix and how to restart the containers in order to load the new config ??

i have also set up a firewall and nginx in front of sentry, both work as expected…

i want to set othe custom settings too like emails etc, but i guess they follow the same logic…

thanks