Typescript sourcemaps present in Sentry but not working


I’ve been struggling on that one for months, tried to make updates (client side, then server side as hosting sentry) etc. But I’ve never managed to get Sentry to show me the errors using my TS sourcemaps.

I’m correctly reporting my errors as I can see them within the panel (for the current release):


And I also can see the Artifacts where there’s all my .js and .js.map.

I recently came across a medium blog post: https://medium.com/angular-athens/make-angulars-source-code-available-to-sentry-with-gitlab-ci-b3020bd60ae6 where everything seems to be up to date and the app built/generated using angular-cli.

I’ve tried before to generate sourcemaps without having them hidden so that the sourcemap tag would appear on JS files. It wasn’t working. Now I’m trying the method where I’m hiding them (just like in the blog post) and it’s still not working.

Do you have any idea of what could be wrong? Seeing all my files in the artifacts tab and the related issue without having the mapping makes me think that I’m eventually missing something or that’s a bug?

Thanks for any help!

Well, nevermind!

Turns out as we’re hosting Sentry ourselves we had issues to access the sourcemaps between the different services of Sentry.

A post that has been helpful: Offline sourcemaps not used