Unable to see suspect commits

Hey there!.

I’ve connected my GitHub account to Sentry in order to get the “Suspect commits” feature working.

I’m creating releases with commits in the Sentry CLI tool and I can see them in the Releases section of the Sentry dashboard.

      sentry-cli releases new -p $SENTRY_PROJECT $SENTRY_RELEASE
      sentry-cli releases set-commits --auto $SENTRY_RELEASE
      sentry-cli releases finalize $SENTRY_RELEASE
      sentry-cli releases deploys $SENTRY_RELEASE new -e $ENV

I’ve created a sample error and it gets reported under Issues, but I don’t see the Suspect Commit UI?

Am I missing something or should this populate automatically after setting up the integration and releasing the version in Sentry?

You’re not alone as there have been a couple other forum posts describing the same issue:

I’ve since reached out to support to see if they have any ideas.

Hey Bryan, thanks for replying. Hoping the Sentry team answers.

I see. Have you tried setting up releases with CLI, API or both?

Do you need to connect artifacts to a release in order for Suspect Commit to work?. I’m reading a guide on https://docs.sentry.io/guides/integrate-frontend/upload-source-maps/ and they are associating the artifacts.

But I’m using normal CRA and the Issues’s stack trace looks correct without publishing artifacts.

Using both currently.

I’m not sure. Uploading artifacts has worked as far as revealing the issue in the stack trace.

Hi @jamzi - is this on sentry.io or on-premise?