Upgrading from 21.6.x to 21.7.0 fails with "Error: It looks like you've skipped a hard stop in our upgrade process"

Sentry version 21.7.0 (that’s what I’m stuck at now, anyway; was 21.6.x prior to attempting upgrade)
OS: Ubuntu 20.04 LTS


I’m attempting to upgrade from 21.6.x to 21.7.0 and when I run the install.sh script, everything looks good until this occurs:

Creating sentry_onpremise_snuba-subscription-consumer-transactions_1 ... done
/usr/local/lib/python3.6/site-packages/sentry/runner/initializer.py:187: DeprecatedSettingWarning: The GITHUB_EXTENDED_PERMISSIONS setting is deprecated. Please use SENTRY_OPTIONS['github-login.extended-permissions'] instead.
  warnings.warn(DeprecatedSettingWarning(options_mapper[k], "SENTRY_OPTIONS['%s']" % k))
13:50:16 [WARNING] sentry.utils.geo: settings.GEOIP_PATH_MMDB not configured.
13:50:35 [INFO] sentry.plugins.github: apps-not-configured
Error: It looks like you've skipped a hard stop in our upgrade process. Please follow the upgrade process here: https://develop.sentry.dev/self-hosted/#hard-stops
An error occurred, caught SIGERR on line 12
Cleaning up...

I did receive a couple of resource warnings regarding minimum requirements, but don’t know if either (particularly the memory) could cause this type of failure:

▶ Checking minimum requirements ...
WARN: Recommended minimum CPU cores available to Docker is 4, found 2
WARN: Recommended minimum RAM available to Docker is 7800 MB, found 5946 M

This failure left the Docker container stack in a half-baked state, and I couldn’t even get to the Sentry UI, so I restarted the stack and while I can login now, I get just the username-dropdown at top-left, and There was an error loading data. [Retry].

I’m not sure how to recover from this scenario, or why the install script complains that I’ve ignored a hard-stop when the referenced documentation makes it sound as though I can certainly go from 21.6.x to the latest version without hitting a hard-stop.

Thanks for any assistance here and let me know if I can provide any additional information.

Have you tried going to 21.6.3 first? We had a bug in earlier 21.6.x causing this issue.

That fixed it! Thank you, @BYK ! I appreciate the prompt and courteous assistance tremendously.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.