CSRF Token issue

Hello there!
I have on-premise sentry instation. Today I’ve updated it from 10.0.0dev0 to 10.1.0dev0, and then sentry stops authenticating me giving CSRF verification failed. Web logs shows

11:25:35 [WARNING] django.security.csrf: Forbidden (Referer checking failed
- https://sentry.domain/auth/login/sentry/ does not match any trusted origins.): /auth/login/s
entry/ (status_code=403 request=<WSGIRequest: POST u'/auth/login/sentry/'>)

I’ve tried set system.url-prefix to https://sentry.domain, also system.internal-url-prefix to the same value, have tried turning on all combination of SSL related configs in sentry.config.py. I asked admin to throw away his config and replace it with one from docs (for SSL nginx proxy), also I dropped out installation entirely and installed from scratch. But problem remains. What i need to check also?

Thank you

Are you using the on-premise repository?

The repo now includes its own nginx, which may be the issue here.

Seems like this is the issue:

Will submit a fix soon, sorry for the issues.