Getting error - Pool is closed

I am trying to install of Sentry On Premis 20.12.1 in Ubuntu 18.04 virtual box.

When I run the install.sh script, I faced the following issue -

  1. Error
ERROR: for snuba-cleanup  UnixHTTPConnectionPool(host='localhost', port=None): Pool is closed.
Couldn't connect to Docker daemon at http+docker://localhost - is it running?

If it's at a non-standard location, specify the URL with the DOCKER_HOST environment variable.
An error occurred, caught SIGERR on line 227
Cleaning up...
  1. Configuration:
  • I also didn’t get what to put in db password and db port sentry.conf.py file
DATABASES = {
    "default": {
        "ENGINE": "sentry.db.postgres",
        "NAME": "postgres",
        "USER": "postgres",
        "PASSWORD": "",
        "HOST": "postgres",
        "PORT": "",
    }
}
  1. As per README -
The recommended way to customize your configuration is using the files below, in that order:

 * `config.yml`
 * `sentry.conf.py`
 * `.env` w/ environment variables

So I put sentry.conf.py, conf.yml file with .env but after running the script, it generates new sentry.conf.py, conf.yml in sentry folder.

  1. There is another observation - getting error from Docker pull “You have reached your pull rate limit”
  2. Also I got - Docker: Having issues installing apt-utils

Can anyone please help me how to setup the configuration and setup sentry on premise.

Maybe you can find a solution here: ERROR: Couldn't connect to Docker daemon at http+docker://localunixsocket - is it running? · Issue #4181 · docker/compose · GitHub

Quick Google on that led me to: Docker-compose : You have reached your pull rate limit (even though it has been more than 6 hours) - Stack Overflow

Is that of any help?

1 Like

You need to put those files under the sentry directory. Sorry for not being clear on this, will update the docs.

@Alexander
I saw those option. But not able to come out the situations.

  • What would be the db configuration?
  • I set in the console export DOCKER_HOST=127.0.0.1:2375 and run using sudo . That’s working now. But now I have 502 Bad Gateway
  • one of the following container is exited -
    sentry_onpremise_geoipupdate_1 /usr/bin/geoipupdate -d /s ... Exit 1
  • Log of that container -
sudo docker logs sentry_onpremise_geoipupdate_1                                                                                                                     ⏎
error loading configuration file /sentry/GeoIP.conf: error opening file: open /sentry/GeoIP.conf: no such file or directory

@BYK

  1. Can you please mention what would be the Postgres Setup.
  2. I can skip the user-prompt by ./install.sh --no-user-prompt. But can I set an admin user and password in the configuration and then run the script?
  3. How can I bootstrap those without manual input?

You can probably leave the default

Should be able to use Sentry without it

Try running this command:

docker ps

What does it say?

The DB configuration is already set so you should not need to change anything. Once you skip the default admin user creation, you can do what we do in our test script to create a user:

docker-compose run --rm web createuser --superuser --email $TEST_USER --password $TEST_PASS
1 Like

Thanks @BYK .

I have another questions regarding Configuration.

From here -Self-Hosted is mentioned to put system.url-prefix in sentry/config.yml file. Is it same system.internal-url-prefix and system.url-prefix?

Nope, they are different settings and you should probably leave system.internal-url-prefix alone unless you know exactly what you are doing.

Ok,
How can I get the url if I install Self-Hosted in AWS ?

It is whatever URL you are going to use to access your Sentry instance (or EC2 instance for your specific case I think).

@BYK
So I installed the Self-Hosted in AWS EC2 . All the containers are up. While I am trying to access Sentry url using the EC2 public IP, Like http://aws_public_ip and The site is not reachable - This site can’t be reached. :frowning:

I didn’t edit any configuration in nginx.conf or anywhere and I am not using any domain as well.

I think I’m missing something.

@BYK

In the security group - port 9000 is open for ingress at 0.0.0.0/0 and egress all port 0.0.0.0/0.

Can you please help me.

Dumb question here: are you trying to access sentry on the right port? Have you tried accessing from that aws-instance?

@Alexander
Yes, might be but I am not able to reach the sentry.
After installing I tried from aws instance to the http://public_ip:9000 . It’s not working.

@Alexander @BYK

Ok, I found it. I am pretty dumb. It was trying to access https, so It was giving not reachable sites.
Thanks

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.