How Relay Docker Instance run with HTTPS Configuration?

We tried to establish a secure connection between our application to relay instance(docker)
As per the documentation, we copied the sentreykey.p12 in the config folder and updated the config.yml.

image

When we tried to execute the relay image then we get the below error.

sudo docker run --rm -it -e RUST_BACKTRACE=1 -v $(pwd)/config/:/work/.relay/ -p 3000:3000 getsentry/relay run
INFO relay::setup > launching relay from config folder /work/.relay
INFO relay::setup > relay mode: managed
INFO relay::setup > relay id: a023ca68-e693-401e-b7d3-4a00dc6acb0a
INFO relay::setup > public key: 0HyA-ZFfWaM6nrZcWEsFau1MeJcBYejBYAsnxgfQ68g
INFO relay::setup > log level: INFO
INFO relay_server::actors::upstream > upstream relay started
INFO relay_server::actors::upstream > registering with upstream (https://sentry.io/)
INFO relay_server::actors::envelopes > starting 2 envelope processing workers
thread ‘main’ panicked at ‘called Result::unwrap() on an Err value: Os { code: 2, kind: NotFound, message: “No such file or directory” }’, relay-server/src/service.rs:213:41
stack backtrace:
note: Some details are omitted, run with RUST_BACKTRACE=full for a verbose backtrace.
INFO relay_server::actors::outcome::processing > OutcomeProducer started.

Kindly help me with this?

As per the logs, the error is:

No such file or directory

I think you would need to specify the absolute path of the location of sentrykey.p12 in your config file instead of relative path. Can you try changing it to /work/.relay/sentrykey.p12 instead of ./sentrykey.p12

Thank you @chhetripradeep for your help.
It works!!