How to get a valid API key for creating releases?

This is what I did:

  1. I opened https://sentry.io/api/
  2. Clicked on “Create New Token” and enabled all permissions (please let me know which permissions are really needed here).
  3. I took the token which appeared in the list.
  4. I used grunt-sentry-release package (my project used grunt) and set apiKey to that token + set up organization, project, version and files there.

when I run grunt task it returns API key is not valid. I also tried to do curls requests manually:
curl -u 14156761a4dc462e92667a4165629c7795afd711a031434392b11a18c5169b57: https://sentry.io/api/0/projects/1/
it returned an empty response
curl -X POST -H "Authorization: Bearer " -H “Content-Type: application/json” -d ‘{“version”: “2.0rc2”, “ref”: “6ba09a7c53235ee8a8fa5ee4c1ca8ca886e7fdbb”}’ "https://app.getsentry.com/api/0/projects///releases/"
where key is computed using node: new Buffer('14156761a4dc462e92667a4165629c7795afd711a031434392b11a18c5169b57:').toString('base64') and organization and project are filled respectively. as for payload, I took it from the docs.
it returned API key is not valid. The same response happened when I did without user:password delimiter.

What I did wrong here?

Psst, I spoofed few characters of the key in this topic, but you know how tokens look like, don’t you?

3 Likes

have the same problem

I’ve also created a token with project:read, project:releases, and project:write scopes. Curling manually with the key also fails in the same way (401 ‘API key is not valid’). I’ve also tried with Base64 encoding, and the response is 401 'Invalid token`

Any insight would be great

Has someone found a solution for the problem? Dealing with the same issue

EDIT: tried with Bearer instead of the documented Basic; worked like a charm with the token I could copy here.

1 Like

It does not work for me :frowning: