POST 404 errors with Sentry v20.7.1

Greetings, all.

I’m seeing some errors after upgrading our Sentry on-premise install from v9.1.2 to the latest v20.7.1. Specifically, it looks like error reports are being made, but Sentry is returning 404 errors for everything. (These worked in 9.1.2.) Below is an example request:

REDACTED_IP_ADDRESS - - [20/Jul/2020:21:12:23 +0000] “POST /api/2/store/?sentry_key=REDACTED&sentry_version=7 HTTP/2.0” 404 0 “https://REDACTED_URL/” “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.116 Safari/537.36” “-”

Under 9.1.2, requests like these always returned a 200 OK response and all was well.

I’m not sure what I should edit to make this work again. Could anyone point me in the right direction? This is a Docker setup, by the way, and I incrementally upgraded Sentry to v10.0.0 -> 20.6.0 -> 20.7.0 -> 20.7.1 via git checkout tags/ and ran each time.

Our data is still intact in the database, it’s just that no new issues are being created in Sentry itself now.

Thank you.

I figured out my issue. Turns out I had another app running on port 3000 that was intercepting requests. I moved it to another port and all is well.

Seems like you’ve solved this but still, make sure you have Relay running properly :slight_smile: