Sentry fetching maps instead using uploaded ones

Hi, I have an issue which I already spent some great amount of time on. Sentry is trying to fetch source code and source maps via http instead using the ones I uploaded. Release ID are a match. I have a next.js app, using SentryWebpackPlugin to upload source maps

process.env.NODE_ENV === 'production' &&
      config.plugins.push(
        new SentryWebpackPlugin({
          include: ['.next'],
          ignore: ['node_modules', '.next/cache'],
          urlPrefix: 'opt/app/.next/',
          release: options.buildId,
          // validate: true,
        })
      )

I tried various prefixes (opt/app is the docker app directory). It works ok via http, but I deleted the maps in production (after uploading them), I don’t want them to be public. What do I do? Please, anyone.

Is this sentry.io or on-premise?

Hi, it’s on premise and we found out the volume with the artifacts wasn’t shared with the workers :man_facepalming:, so it works now. But I am dealing with another problem - the stack trace paths, some go

onClick(/_next/static/xSSxRazgIHgi1qtFb0LZ6/pages/about.js)

and others

doAsyncWork(app:///opt/app/.next/server/static/xSSxRazgIHgi1qtFb0LZ6/pages/about.js)

and I need the beginning of the paths to be the same (starting from either /_next/ or /.next/ or both starting with /opt/app/) so I don’t have to upload the maps twice with different prefixes. I tried to use the root property of RewriteFrames but it can’t replace the beginning of the paths, just appends it. I think it’s a next.js thing maybe?