Sentry slack integration error


So, i’m trying to integrate sentry plugins, and have some problems with that.

  • Sentry v.8.20.0
  • Sentry-plugins v.8.20.0

At first - i made custom docker image based at library/centos7 with sentry and sentry-plugins.
Sentry/plugins installation was made by that way at :

  1. clonning *.zip from github
  2. unzip that
  3. and then SENTRY_BUILD=9 pip install .

When i’m trying to test slack integration, i’m getting:
“There was an internal error with the Plugin”

Traceback (most recent call last):

File "/usr/lib/python2.7/site-packages/sentry/api/endpoints/", line 55, in post
     test_results = plugin.test_configuration(project)
   File "/usr/lib/python2.7/site-packages/sentry/plugins/bases/", line 167, in test_configuration
    return self.notify(notification)
   File "/usr/lib/python2.7/site-packages/sentry_plugins/slack/", line 159, in notify
     group =
AttributeError: 'NoneType' object has no attribute 'group'
07:12:07 [ERROR] root: Plugin(slack) raised an error during test`

So, i’m trying to modify with that:
print notification.__dict__
event = notification.event

And get:
{'rules': [], 'event': None}

What i’m doing wrong?

Thx for help.

some upd:

  • supervisor in docker image is s6-overlay (i really doesn’t think, that this problem chained with workers, but who knows… )
  • similar behaviour with webhooks

I don’t really know what you’re doing wrong, but I’ll point out a few things:

  • we don’t support CentOS. This is unlikely this very specific issue, but you will most likely run into other issues based on the number of people who complain about things not working on CentOS right.
  • the error you’re getting seems more like a cascaded error. During the test plugin thing, it inserts an error into the database, then passes that along for notification. So my guess is that somewhere, something else is failing first. Then passing along bad state here.

My fault.

I’m used postgresql:9.6 docker image instead postgresql:9.5.

Changing this solved my problem.

Thanks anyway!

Was there more to the error? Are we just broken against Postgres 9.6? I’m really concerned if that’s the case. :confused:

I’m continued my investigation, now with postgresql:9.5-alpine docker image.

So, in result i received that:

  • slack notifications send’s at first seen ( yes, i’m trying to change alert rules and check on/off it : )
  • test plugin button still give return me “There was an internal error with the Plugin” with same notification object attribute

Tomorrow i will try to test it with ubuntu image.

And if it will work - then will start to debug my centos image.

Okay, what i’m investigate today with Centos7 docker image:

  • slack plugin can’t work with alert rules “on the fly” (need to on/off plugin)
  • “Test plugin” button still not working as it should (i don’t receive test message, but i received error message, that button doesn’t work : )

I’m still not trying to build sentry with plugin at ubuntu docker image (have so few free time).

That’s all at this moment.