Source map artifact not being applied (Webpack)

The problem in a sentence: Our source map is properly configured and uploaded alongside the minified file using the automatic Webpack solution suggested in the JavaScript docs of Sentry but the original, unminified file does not appear in the stacktrace of

We are currently developing an application with electron-vue that automatically bundles files into a few minified source maps using Webpack.

I have configured Webpack to use the source-map style in the devtool field of webpack.main.config.js which correctly creates a file alongside main.js.

I’ve verified that this map works according to the troubleshooting section in the docs. I’ve verified that the artifacts do show up in the correct release.

The artifact names also match the sourceMappingURL as seen in the stacktrace:

I’ve also verified that the source map works correctly locally using the npm source-map package suggested on the page.

Any suggestions? I’ve viewed quite a few forum threads with similar issues to no avail. Could it also be that the source file (src/main/index.js) is in a different directory? I’ve experimented with urlPrefix as an optional argument for sentry-webpack but haven’t been successful either.

I have the same issue and no solution yet. Sentry for some reason doesn’t math the sourcemaps.


Andre, I have the same issue as you - artefacts uploaded as you have them (i.e. nested in directories), and the sourceMappingUrl is relative to the directory that the original file is in.

Did you ever get his solved?

Same error trying to present my activity as a web developer, build my website with React, and everything is fine, it is just the last piece missing, anyone with the solution ? I’ve seen a post on medium talking about url-prefix but dont know what to put inside, and it is not a “sentry webpack plugin attribute”