Sourcemap Artifiact Help

I recently deployed my sourcemaps to sentry and cannot seem to link them up. I have followed the docs but for some reason, sentry never seems to look at the release artifacts and always gives a 404 that it can’t find the actual sourcemaps on my server.

Example below:

Via the cli, I successfully upload a js file with a valid sourcemap under release ‘stage-08.17.2017’
~/main.d4bd25c6d38d9862951f.bundle.js (sourcemap at

In my Project > Releases > stage-08.17.2017 > Artifacts I see the file
~/main.d4bd25c6d38d9862951f.bundle.js ~/

I trigger the error and go see the event in sentry under my ‘New Issues in this Release’ .
The error says ‘There were 4 errors encountered while processing this event’. 1 is an invalid parameter and the others are below.

HTTP returned 404 response on http://my-staging-url/

HTTP returned 404 response on http://my-staging-url/

HTTP returned 404 response on http://my-staging-url/

My upload-sourcemaps flags are minimal upload-sourcemaps dist/ --validate

My .js files has

Sentry-cli is version 1.19
Hosted Sentry is 8.19.0

I don’t understand why it always looks at my server (where I do not keep the sourcemaps) and won’t look in the artifacts. Any help would be greatly appreciated.

You should also prefix this URL with a ~.

Did you similarly upload these as artifacts?

This is actually not necessary, the url can be relative and this is what sentry-cli uses automatically.

Does this happen on or self hosted?

This happens on self hosted. The artifact name is prefixed with ~ according to the UI in sentry. The soourcemap URL in the minified files is not but I have tried appending it myself and it doesn’t change the outcome.

Bottom line, I cannot seem to figure out how to force sentry to see the artifacts I uploaded. It only looks on my server and then fails when it cannot find it.

My only guess right now is that you have a very old version of sentry that does not support this yet. Which version of sentry are you running?

We are running Sentry 8.19.0

running Sentry 8.19.0 ,confused with the same issue. Always it ignores the artifacts files (the name and version are ok) when the error event happens. Has anyone solved?

Does this still happen on newer versions?