TRACE_SAMPLE_RATE of 0.05 still showing 100% of transactions

We have a Django app running in a Docker Swarm container. Initially when we set up Sentry on-prem, we set the trace_sample_rate to 1. We determined that this was too much so we agreed and switched it to 5% or 0.05. We have confirmed the container shows 0.05 for the rate but the Sentry Project screen is still showing 100% of transactions based on the total. Is there any where else we could look or a setting we missed that would cause the TRACE_SAMPLE_RATE to not work?

1 Like

Iā€™m seeing a similar issue with a Django app deployed to Docker container managed by kubectl. The trace_sample_rate is set to 0, but transactions are still flooding the Sentry Project.

Update: found that an older instance of our container was running on another machine. It had been provisioned with trace_sample_rate = 1, which explained the influx of transactions when none were expected.