Upgrading 9.1.2 to 20.* events show "There was an error loading data."

I’ve used Sentry for a few years, always inside docker containers.

I was able to upgrade it to 9.1.2 successfully (from 8.22.0), and everything seems to work fine.

I am trying to get it up to 20.9.0, and I’ve tried upgrading from 9.1.2 to 10.0.0 and then each increment, one-by-one, and I’ve tried upgrading directly from 9.1.2 to 20.9.0, and I’ve tried using the install.sh script and “sentry upgrade”. I am able to get the system upgraded to 20.9.0 in all cases, but with varying problems. Either the “issues” are all missing or, more recently, the issues are listed properly, but clicking on them yields the message “There was an error loading data.” on screen and I can see a 404 in response to the API call that grabs the event details (ex: GET /api/0/issues/374457/events/latest/ returns 404 with ‘{“detail”:“Event not found”}’).

I was having trouble with the migration “sentry.0024_auto_20191230_2052”, which gives a huge number of errors like “Skipped <sentry.eventstore.models.Event object at 0x7f281ca8a290> as group, project or node data information is invalid.”. I saw this issue mentioned in a very recent commit, so I’ve re-run the upgrade from the master branch and it does indeed resolve that problem, but then I’m still left with the problem of being able to see all the issues without being able to click on any of them because the event details API calls fail.

I’m currently at commit dcc7fa4e6fb68383af591130a2ae2801639bd40a (Mon Sep 28 23:08:41 2020 +0300), so I’ll pull the latest changes and see if that has any effect.

Any ideas?

3 Likes

Hi,

Thanks a lot for following us all the way from 8.22.0! :slight_smile: Sorry you had issues with the upgrade. Are you able to provide more logs so we can investigate?