Webhook does not work

Hi, we’ve met an issue about webhook with Zulip. Previously it worked fine, but now it doesn’t trigger the webook for months.

I’ve tried to test it via webhook config page by clicking “Test Plugin” button, it notified me:

Test Results:
“No errors returned”

But nothing happened on zulip side. (the webhook link works, I’ve tested it many times).

And here is logs when I tested webhook (only in sentry-web, nothing happend in sentry-worker):

2021-07-14T02:00:15.691185901Z10.36.2.16 - - [14/Jul/2021:02:00:15 +0000] "POST /api/0/projects/sentry/api-staging/plugins/webhooks/ HTTP/1.1" 200 445 "https://sentry.t20t.co/sentry/api-staging/settings/plugins/webhooks/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.124 Safari/537.36 Edg/91.0.864.67"

Also I am not sure if this could be helpful for you to analyze, I’ve observed lots of webhook logs in sentry-worker log, but they are all similar:

2021-07-14T01:55:33.042343603Z01:55:33 [INFO] sentry.plugins.webhooks: notification.dispatched (project_id=7L plugin=u'webhooks' rule_id=8L group_id=41328L)

it seems that something is going to trigger webhook, but nothing actually happens.

Also I’ve tried configure webhook with a non-existing url, I guess the expected behaviour should be raising some exceptions because of request failure. But still nothing happens, only the notification.dispatched logs appeared.

Can anyone help on this?

Hi anyone can help on this? or should I raise a GitHub issue instead?