All http header, query string and body parameters are shown [Filtered] by data scrubber

Today after renaming organisation name, project name and modifying alert email subject, I noticed server-side data scrubbing doesn’t function properly as expected and it worked in the past. It shows all http header, query string and body parameters “[Filtered]” which is abnormal behaviour.

  Content-Type: [Filtered]
  User-Agent: [Filtered]

Query String:
  q: [Filtered]

Body: "cosName=[Filtered]&address=[Filtered]&password=[Filtered]&firstName=[Filtered]&lastName=[Filtered]"

Other relevant configuration is: Use Default Scrubbers option is enabled, Additional sensitive fields and Safe fields are empty. Sentry version is 8.14.0.dev0

What are the values of your scrubber settings? You can find these in your general configuration in your project settings, they look like this:

Are you using self-hosted Sentry, or are you on

We are using, and as explained above:

  • “Data Scrubber” is enabled
  • “Use Default Scrubbers” is enabled
  • “Additional sensitive fields” is empty
  • “Safe fields” is empty

Everything was fine for couple of months till yesterday when I modified organisation name, project name and alert email subject.

Also, we have another project in which is used only for development and testing purposes, we experienced same issue when I ran our own dummy events generator.

This same thing started happening for us today after performing several org.edits. Everything in tracebacks/additional data sections show as [filtered]. It appears to effect all projects/teams.

Sorry about that @mehretaban, I read through your post too quickly (end of the day and all that) and totally missed those details, but thanks for clarifying. We identified the the issue and have a committed a fix here.

Thanks for addressing the issue. May I know what is its fix version and release date (deployed into ?

It was deployed minutes after it was merged.