Allow release versions like @sentry/node@1.0.0


#1

At the moment we can add release like sentry/node@1.0.0 through Sentry.init method. It generates the release in Sentry, however, whenever trying to access the release page from Sentry I get: “There was an error loading data.”

After trying to add the same release name through the API I get: "version": ["Invalid value for release"]

So I believe it could be a good idea allowing release names like the above for monorepos, etc?