Flutter iOS sentry-cocoa SDK not reporting all crashes

So we’ve integrated the sentry-cocoa SDK, and we’ve confirmed it is reporting crashes to the right project for several different types of crashes. However, there’s a particular crash from a user that we’ve been unable to reproduce that we do not get reports for. We had the user crash the app two other ways, and we did get those crash reports.

Are there particular circumstances, or a particular type of crash where the sentry-cocoa SDK is unable to catch and report it? Our app is built with Flutter (we have Sentry integrated on the Flutter side and do report unhandled exceptions there), the device is running iOS 12.4 and it is an iPhone 6 Plus.

Our current Flutter support doesn’t capture native (Java/Kotlin and Objective-C/Swift) crashes.

We’re working on it. This repo has examples already that crashes and get captured by our native SDKs, we’re working on releasing this soon.

Yes, that’s our understanding, which is why we added sentry-cocoa on top of the Flutter Sentry SDK. To be clear, we’ve integrated both the Flutter SDK, and the native sentry-cocoa SDK for Swift.

As mentioned above, we are able to capture most native crashes. We’ve simulated several native crashes and they are captured in Sentry on this device. However, there is another native crash that is not being captured by sentry-cocao. Our question is whether there is a particular type of native Swift crash or particular circumstances that would prevent a native crash from being reported by sentry-cocoa?

Oh my bad, when I read Flutter I went straight to that without consider you could have added it manualy/gone in detail to your question.

I believe OOM could be a reason, but other than that I don’t know what kind of error could happen that our sentry-cocoa SDK would not capture.

We’ve been battling something similar. Recently, we haven’t gotten any crash reports. To try to debug this we even setup a new testing account on sentry.io, created a dumb ios project, installed the pods, and tried to report a crash in the simulator. Nothing even on the new account and project.

In the past, it just worked, so we were caught off guard when we went looking for a crash that I experienced personally and it wasn’t there.

Is your app also Flutter based? If not do you mind opening another post and describing the steps we can reproduce it? What version of the SDK you’ve tried and how did you initialize it.