Geolocation doesn't work on default sentry


I cloned the default sentry/onpremise and then according to I copied the GeoIP.conf file into onpremise/geoip and after that I ran the Sentry installed correctly and even the GeoLite2-City.mmdb got created in the onpremise/geoip folder. When I run docker-compose up -d sentry starts and works just fine but the container sentry_onpremise_geoipupdate_1 turns off with exit code 0 right after it is turned on without any error message in the console to indicate what’s wrong.

Thanks for the help in advance.

Sorry for the confusion @martbc, that’s actually expected behavior. sentry_onpremise_geoipupdate_1 is a batch job to update the GeoIP database, once updated, the information is used by other long-running containers. I made a PR to add this note to the GeoIP docs.

1 Like

Thanks for the clarification, so the geolocation should be working just fine then ? I read somewhere that you have to have “send-default-pii” set to true in your application, is that correct ?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Doesn’t ring a bell but seems plausible. Link?

There are instructions in the geolocation docs on how to confirm it’s working. Hopefully it is for you? :slight_smile: