GitHub SSO client_id empty after upgrade from 9 -> 10

We updated our Sentry On Premise and now we cannot log in.

We also switched to the new system of SSO with GitHub, but we have not been able to log in since then.

  1. How can we allow login with username:password again?
    We want to enable that login again to help us debug.

  2. How can we debug why the client_id does not appear in the URL when we click ‘Login with GitHub’

Below is the URL string, formatted and sensitive info replaced with ‘XXX’

As you can see, client_id is empty in the URL string.

If I run the following inside the web container, it responds with the string.
sentry config get github-app.client-id
from config: XXX
current: XXX

Try to add GITHUB_APP_ID = “your_id” and GITHUB_API_SECRET = “your_secret” into and run

Thank you @misyurev, that solved it!

But why do we now need to have the ENV in 2 places?
The values were already in config.yml like the documentation stated.

github-app.client-id: 'XXX'
github-app.client-secret: 'XXX'

Is this a bug?
As stated above I went into the container and queried the app what the values were, making me believe the app already knew the correct values.

I’m pretty sure this is a bug. I’ve spend a lot of time to fix that issue in my on premise installation

@BYK from the past here, sorry for the very late response. We had some issues around GitHub integration configuration as we need 2 separate apps:

  1. An OAuth App for SSO login
  2. A GitHub app for GitHub integration

We tried to (unsuccessfully) unify these and then after the failure, didn’t do a great job updating our docs or the example config.

Expect to see better docs around this in the near future and apologies for the inconvenience.