Help needed adding a private GitHub repository


#1

I’m having difficulty adding a private GitHub repository via the Repositories section of the app. I’m attempting to add a repo (to which I have admin privileges and is part of a GitHub organization) via Add Repository > GitHub > org/repo_name + Save Changes.

I keep receiving a 404 response. I’m assuming this is a permissions issue within GitHub?

I have permitted Sentry access within GitHub to the organization via “Third-party access”.

What am I doing wrong?

Thanks.


#2

You need to be either a Manager or Owner in Sentry in order to be able to add repositories.


#3

I am having a similar issue and I am a Manager in Sentry. I get the same 404 response (and in Github, i do have access to the private repository)


#4

Can you try these steps and see if they help?


#5

I am an owner in Sentry, and as I mentioned above I’ve given Sentry access within GitHub.

What should I try next?

Thanks.


#6

Can you make sure you have the correct GitHub identity set up in Sentry? You may need to disconnect and reconnect with the correct identity. https://sentry.io/account/settings/identities/.


#7

I followed the steps above in the help article and I can confirm Sentry has access to the organization on Github. I also have the correct Github identity set up in Sentry.

What can I try next? Thanks for your help.


#8

Do you have Admin or Owner permissions for the GitHub organization? That’s needed for the webhook.

https://help.github.com/articles/repository-permission-levels-for-an-organization/#changing-repository-settings


#9

I think that was it, I don’t have admin / owner permissions on the Github organization. I asked the owner of our Github org to add the repo to Sentry and it worked.

Thanks!


#10

That was it! Reconnecting with the correct GitHub identity fixed the issue.

Thanks.


#11

Hi everyone,

I am having the same problems and I can’t seem to connect Sentry with Github.
I did all of the above and even reconnecting with my github identity and it still doesn’t work. Even I can’t send an issue to my own public repo (not part of an organization)

please help


#12

Oh nevermind :slight_smile: I fixed it :slight_smile:


#13

Hello people, with me the problem is a bit different. I keep getting “Unable to save changes. Please try again” message after trying to add my organization repo on Github. I’m admin on sentry and owner at Github. Looking at the request the add button is making (POST https://sentry.io/api/0/organizations/<org>/repos/), I can see that it’s returning 403 ({“detail”: “You do not have permission to perform this action.”}).

Any idea what is going on?

Thanks!