Incorrect SAML2 configuration , disable SAML2 login page

Anyway to disable default SAML2 login page . Our Idp certs need to be renewed , but i am unable to go to the default login screen

I tried this. But no change.

SENTRY_FEATURES['organizations:sso'] = False
        feature: True
        for feature in (

Tried all options, here. Even set this to multi organization mode. but that dint work.

@BYK , any insiders on this? how to disable the SAML2 login. I need change the IdP cert and the URL.


You can try two things:

  1. The correct feature flag is organizations:sso-saml2, try disabling that instead
  2. Use the interactive shell (docker-compose run --rm web shell) and then run the following:
    from sentry.models.authprovider import AuthProvider
    To get the list of auth providers installed. Very likely you’ll get only one and then you can do AuthProvider.objects.all().delete() to delete all of them (or pick the SAML one using object indexing and run delete() on that only.

Awesome that worked! Thank you @BYK

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.