On-Prem 9.1.1, no way to get SSO (SAML2) working


has anyone managed to get the current Docker-Install (9.1.1, Docker-Base 9.1) working with SAML2 or anything else?
I tried every config-switch I could find in the forums (mainly:

SENTRY_FEATURES['organizations:sso-saml2'] = True
SENTRY_FEATURES['organizations:sso-rippling'] = True

) and documentation and tried to install this from here: https://github.com/getsentry/sentry-auth-saml2 which works, but also does not lead to any auth-providers showing up in the auth-menu (just finding google there). I also tried without installing that.

I would appreciate any hint on how to get this working.



Its enabled by default in current releases, and once you’ve installed the plugin you will find the providers under your organization’s settings -> auth.

You can confirm you’ve actually installed the package (at least in the web UI) by visiting this URL:


now I’m trying to do it with 9.1.2.
I see in the source code that the extensions enable by default .
I’m searching for sso-saml2 in the packages list (like @zeeg added in his comment and I didn’d find it).
I see only google sign in.