Issue logging into self-hosted Sentry for the first time

Hi, I’m trying to run Sentry locally (just to try it out before implementing it in production), and I feel like I must be missing a step with the setup. I cloned the repo (tag 21.3.0), ran ./install.sh, and then docker-compose up.

That all went fine, but then when I went to localhost:9000 and tried to sign in (using the account I made on sentry.io), it wouldn’t let me sign in. I think this makes sense, since I assume the self-hosted login wouldn’t be the same as the one I created on the actual site, but I’m not sure how to proceed from here.

I tried clicking the ‘Request to Join’ button, and entered my email, but nothing seems to have happened. When I click ‘Lost your password?’, I do get an email, but all the links in the email are weird and look like x-webdoc://CAF3FCE1-ECD0-4997-8533-10B562A2FE75/account/recover/confirm/1/BkT2zljVCioNor2YDNLIHaXsPM2XXrya/, which I don’t know how to open. I think I must be doing something wrong. Any pointers would be appreciated!

Hi there, perhaps you can try running ./install.sh --no-user-prompt and then following the printed steps to create a user via cli before launching the UI.

1 Like

Brilliant, thanks!