Lost host connection during and after installation

Hello,

I installed Sentry on premise last friday and everything was fine.
I have tried to do it again since yesterday but I am losing the host ping after installation

Environment : Centos 7, docker 20.10.2 and docker-compose 1.27.4

I launch the installation and the host ping at the same time. The ping response is ok

After the command "creating network “sentry_onpremise_default” with the defalut driver, no more response from the ping of the host.

When the installation is done, the host is unreachable. I can’t access to http://host:9000/sentry.

Hope the message is clear, with enough details.
Someone can help me please ?
Greg

It might be running out of memory or disk space.

Thank you for the replay.

The first time (last thursday), I tried to install Sentry and yes, there was not enough space on the disk but the message from the installation was clear (no space left…) and it failed. So, I added 30 G

The host has 10G Mem Free, I hope that’s enough.

Like I said, the installation succed on friday last week, the host and Sentry was available. But now, I lost the connection with the host as soon as the command line “creating network “sentry_onpremise_default” with the defalut driver” is executed during the installation.

I noticed that there was more informations between friday and monday (Applying sentry.0…), a deployment this weekend?

Greg

Everytime you install Sentry, docker-compose deletes and then creates a new internal network. It binds the Nginx container to the host’s port 9000 so this shouldn’t really matter. That said if you are sure this is the issue, I’d check my firewall (iptables?) settings, especially around Docker and internal networks.

I forgot to tell you something important. I install Sentry on a virtual machine.

I took a snapshot of my VM with only docker and docker-compose just before installing Sentry and if I start docker without Sentry, I don’t lose the ping.

And, I restore the snapshot before I start an installation of Sentry.

On Friday, Sentry works perfectly on http://myVM:9000/sentry
Since Monday, I restore myVM with the snapshot, restart the installation and I cannot acces on http://myVM:9000/sentry

Do you have any logs from docker-compose?

I finally found the problem. You were right, it was a problem between docker and internal network. Docker use 172.17… like our network.

Now, I’m trying to plug Sentry with Gitlab but the redirect uri that Sentry propose is localhost

It’s not the right value, it should propose the hostname of sentry

Do you know how i can change the redirect uri ?

Thank you for your help

Glad you figured it out!

Sounds like you need to set your system.url-prefix: https://develop.sentry.dev/config/#general

Great, your answer helped me and now gitlab is installed but can’t configure.

When I try to add repository, I see a repository and click on it but I have this message

Do you have an idea ?

It seems that Gitlab accept only https request and my server nginx with Sentry is only on http.

Well done, I activated http request in Gitlab and It works.

Thank you so much for your help.