Sentry not working with c# .NET Framework 4.8

I installed onPrem version and am experimenting with it a little bit. I downloaded the samples and was able to run the .NET Core version but when I run the same code in .NET Framework 4.8, it doesn’t record any errors/ info in sentry. Is there a reason why this would happen?

I do not see any issues when the code is executing but don’t see any logging either. Is there a way to check what is happening?

EDIT: I was able to run a new project and see the error on sentry dashboard but still not idea why my main project doesn’t. I have commented out everything else in the program.cs

It is very hard to understand what is going on here. Do you think this is related to self-hosted Sentry or .NET SDK itself? (tagging @bruno-garcia in case as he is our .NET expert)

Have you tried setting the SDK in debug mode?
There are some docs on it here; Basic Options for .NET | Sentry Documentation

The .NET SDK also has a swappable internal logger, if you need to write to a file or somewhere else (for cases such as WPF that don’t have a console to see the output):

@bruno-garcia I haven’t. I am going to give this a try

Thanks