Sentry on docker-compose behind nginx bad links


When setting up an instance of sentry though docker-compose, running it locally works perfectly, but we put it behind an nginx server so the nginx handles ssl, but then when going to some of the links (for example, to Auth section in the organization dashboard) the links for other sections get changed to ‘hosntame.local:9000’ instead of the nginx https url. It only happens with some of them. A college told me that it might be the ‘client routing’, but I’m not sure how to solve it.

It might be that I’m missing something in the configuration.

Any ideas are welcome.

I think I found the solution… I had to add to the config.yml the option ‘system.url-prefix’ to the value of the external url :smile: now it works as expected!

It still puts the wrong urls in the emial templates though… looking

I think you have to setup the URL of your instance in the admin section of the site.

Just to make sure : you’re serving your sentry at the root of your domain or are you trying to have ?