Sentry run web command uwsgi segfault

I am trying to install sentry on one of a server, following this guide,

But when I try to start the server, I got this error segfault while doing this command
sentry --config ./ run web

*** Starting uWSGI 2.0.16 (64bit) on [Sun Feb 11 14:21:21 2018] ***
compiled with version: 4.8.2 on 11 February 2018 13:27:04
os: Linux-2.6.32-431.11.2.el6.x86_64 #1 SMP Tue Mar 25 19:59:55 UTC 2014
nodename: wqrgrid1087
machine: x86_64
clock source: unix
pcre jit disabled
detected number of CPU cores: 48
current working directory: /home/trle/sentry
detected binary path: /home/trle/sentry/bin/uwsgi
dropping root privileges as early as possible
your processes number limit is 40960
your memory page size is 4096 bytes
detected max file descriptor number: 364076
lock engine: pthread robust mutexes
thunder lock: enabled
uwsgi socket 0 bound to TCP address fd 3
dropping root privileges after socket binding
Python version: 2.7.6 (default, Apr 5 2014, 12:50:38) [GCC 4.8.2]
Set PythonHome to /home/trle/sentry
Python main interpreter initialized at 0x1ef93e0
dropping root privileges after plugin initialization
python threads support enabled
your server socket listen backlog is limited to 100 connections
your mercy for graceful operations on workers is 60 seconds
setting request body buffering size to 65536 bytes
mapped 1924480 bytes (1879 KB) for 12 cores
*** Operational MODE: preforking+threaded ***
dropping root privileges after application loading
spawned uWSGI master process (pid: 25689)
spawned uWSGI worker 1 (pid: 25707, cores: 4)
spawned uWSGI worker 2 (pid: 25708, cores: 4)
spawned uWSGI worker 3 (pid: 25709, cores: 4)
!!! uWSGI process 25707 got Segmentation Fault !!!
!!! uWSGI process 25709 got Segmentation Fault !!!
*** backtrace of 25707 ***
[Sentry] uWSGI worker 1(uwsgi_backtrace+0x2e) [0x46befe]
[Sentry] uWSGI worker 1(uwsgi_segfault+0x21) [0x46c291]
/lib64/ [0x7f525ab736a0]
/home/trle/sentry/lib/python2.7/lib-dynload/ [0x7f5253287d2e]
/home/trle/sentry/lib/python2.7/lib-dynload/ [0x7f52532880dc]
/dat/wqdata/stable/Python-2.7.6/lib/ [0x7f525b212f6b]
/dat/wqdata/stable/Python-2.7.6/lib/ [0x7f525b213a03]
/dat/wqdata/stable/Python-2.7.6/lib/ [0x7f525b21446d]
/dat/wqdata/stable/Python-2.7.6/lib/ [0x7f525b2145a2]
/dat/wqdata/stable/Python-2.7.6/lib/ [0x7f525b22be3c]
/dat/wqdata/stable/Python-2.7.6/lib/ [0x7f525b22c19e]
/dat/wqdata/stable/Python-2.7.6/lib/ [0x7f525b22d099]
/dat/wqdata/stable/Python-2.7.6/lib/ [0x7f525b22c19e]
/dat/wqdata/stable/Python-2.7.6/lib/ [0x7f525b22d099]
/dat/wqdata/stable/Python-2.7.6/lib/ [0x7f525b22dcd3]
/dat/wqdata/stable/Python-2.7.6/lib/ [0x7f525b20c3af]
/dat/wqdata/stable/Python-2.7.6/lib/ [0x7f525b15d7c3]
/dat/wqdata/stable/Python-2.7.6/lib/ [0x7f525b15d91b]
/dat/wqdata/stable/Python-2.7.6/lib/ [0x7f525b22eaa2]
/dat/wqdata/stable/Python-2.7.6/lib/ [0x7f525b22ec1a]
[Sentry] uWSGI worker 1(uwsgi_python_reset_random_seed+0x10) [0x481370]
[Sentry] uWSGI worker 1(uwsgi_python_post_fork+0x2a) [0x482a7a]
[Sentry] uWSGI worker 1(uwsgi_run+0x22e) [0x47115e]
[Sentry] uWSGI worker 1() [0x41ffee]
/lib64/ [0x7f525ab5fd5d]
[Sentry] uWSGI worker 1() [0x420019]
*** end of backtrace ***
!!! uWSGI process 25708 got Segmentation Fault !!!

Versions of things:
~/sentry $ ldd which python => (0x00007fff111b0000) => /dat/wqdata/stable/Python-2.7.6/lib/ (0x00007f8abcd41000) => /lib64/ (0x00007f8abcb0b000) => /lib64/ (0x00007f8abc906000) => /lib64/ (0x00007f8abc703000) => /lib64/ (0x00007f8abc47f000) => /lib64/ (0x00007f8abc0ea000)
/lib64/ (0x00007f8abd165000)

~/sentry $ ldd which uwsgi => (0x00007fff66806000) => /lib64/ (0x00007fc485672000) => /lib64/ (0x00007fc4853ee000) => /lib64/ (0x00007fc4851e9000) => /dat/wqdata/stable/postgresql-10.2.1//lib/ (0x00007fc484fcd000) => /dat/wqdata/stable/pcre-8.35/lib/ (0x00007fc484d7f000) => /lib64/ (0x00007fc484b7a000) => /usr/lib64/ (0x00007fc48490e000) => /usr/lib64/ (0x00007fc48452e000) => /dat/wqdata/stable/libxml2-2.9.1/lib/ (0x00007fc484160000) => /lib64/ (0x00007fc483f5d000) => /dat/wqdata/stable/Python-2.7.6/lib/ (0x00007fc483b3b000) => /lib64/ (0x00007fc483903000) => /lib64/ (0x00007fc48356f000)
/lib64/ (0x00007fc4858aa000) => /dat/wqdata/stable/postgresql-10.2.1//lib/ (0x00007fc483315000) => /dat/wqdata/stable/postgresql-10.2.1//lib/ (0x00007fc48301f000) => /lib64/ (0x00007fc482e1b000) => /dat/wqdata/stable/postgresql-10.2.1//lib/ (0x00007fc482bd5000) => /usr/lib64/ (0x00007fc48295d000) => /dat/wqdata/stable/postgresql-10.2.1//lib/ (0x00007fc48275a000) => /dat/wqdata/stable/postgresql-10.2.1//lib/ (0x00007fc48254d000) => /lib64/ (0x00007fc482332000)
‘default’: {
‘ENGINE’: ‘sentry.db.postgres’,
‘NAME’: ‘postgres’,
‘USER’: ‘trle’,
‘HOST’: ‘’,
‘PORT’: ‘’,

I do not have any ideas what might cause this kind of segfault @@
Machine is on centos 6.5 (but i think it’s not quite an issue)

Ive never seen this issue before, but I can say we don’t support CentOS.

Ah maybe the python package i used has some error, tried another python package and it seems working well now

Same issue over here!

I installed Sentry from scratch, following the (deprecated) python way (and also the docker way) and the two of them take me to the same error.

In this case, I’m using ubuntu 16.4 and my “uWSGI workers” are dying and restarting again and again. I cant get the Sentry web server running :frowning:

Any idea? @matt

to my experience, please try another standard python distribution, i switched to use another and it works

Thanks for you suggestion @sandcoffin. I’ve been trying with python 2.7 (as the documentation says) and got the worker’s error.

After reading your suggestion, I ran the installation with the latest Python and pip versions, but it doesn’t work. When I start the Sentry installation some tests failed and the installation stops, I ran them again with Python 2.7 and I was able again to install Sentry, but cant run due to the same worker’s error.

I’ll let you know when I reach a solution.

UPDATE: I can see these lines at the postgres log

LOG: could not receive data from client: Connection reset by peer
[unknown]@[unknown] LOG: could not accept SSL connection: Success

The last log line (indicating the SSL issue) is repeating all over the time while sentry run web is running.