Setting up with plugins using Docker

Hi. I’m currently setting up Sentry onpremise using Docker. I’ve not use Docker before. I got a basic Sentry setup working, but wanted to add the plugins. I added the sentry_plugins repo to requirements.txt, but this then complained about node being missing.

To fix this, I tried adding “RUN apt-get install -y --no-install-recommends nodejs” to the Dockerfile, but this continued with the same error. I believe this is because this RUN command is run after the ONBUILD RUN in the parent Dockerfile.

To fix this, I replaced the Dockerfile from the onpremise repo with the onbuild Dockerfile from the docker-sentry repo, and added the RUN apt-get command below the FROM line. This complained it couldn’t find the nodejs package.

I then tried using the curl method to install nodejs as per the instructions. This complains about curl not existing, so I tried adding a command to install curl. This complains about the curl package not being found. So I think I’m misunderstanding something fundamental with regards to how the docker build process works.

Gist with my current dockerfile and copies of the error reports:

Does anyone know of a fix or a better way to get Sentry installed with plugins?

Thanks in advance

Just hang in there for 8.10. :slight_smile: sentry-plugins isn’t quite ready for prime time yet, and 8.10 will bundle sentry-plugins in the image by default.

When is 8.10 expected to release? (Are we talking days, weeks or months?)

Should I be using the individual plugin repos (which have big fat “deprecated” notices on them telling you to use sentry_plugins) in the meantime?

@AllenJB we release Sentry once a month, so roughly in a week (around Nov 1st) 8.10 will be available.