Should I have at least one plug-in at requirements.txt?

I am trying to set up sentry with Docker.

sds@sds-VirtualBox:~/dev/onpremise$ sudo make build
==> Building sentry-onpremise:latest
Sending build context to Docker daemon 16.9 kB
Step 1 : FROM sentry:8.13-onbuild

Executing 4 build triggers…

Step 1 : COPY . /usr/src/sentry
Step 1 : RUN if [ -s requirements.txt ]; then pip install -r requirements.txt; fi
—> Running in 4f817f6d5f29
You must give at least one requirement to install (see “pip help install”)
Step 1 : RUN if [ -s setup.py ]; then pip install -e .; fi
—> Running in f32466086b89
Step 1 : RUN if [ -s sentry.conf.py ]; then cp sentry.conf.py $SENTRY_CONF/; fi && if [ -s config.yml ]; then cp config.yml $SENTRY_CONF/; fi
—> Running in 9cbcff214262
—> 6dd3316ecfaa

You must give at least one requirement to install (see “pip help install”)

Should I have at least one plug-in at requirements.txt?

GitHub
JIRA
Hipchat
Slack
GitLab
Phabricator
Pivotal Tracker
Pushover
Flowdock
Redmine
BitBucket
Trello
IRC

Can I write one of them as a plug-in? Is it right?

You don’t need to. That’s just a warning because it’s trying to install nothing. But if you don’t need to install anything extra, it’s harmless.