Sourcemaps failing

I am having problems with my sourcemaps in Sentry, currently I am seeing this:

webpackJsonp([0],{"+46C":function(t,e,r){var n=r("NO+i");"string"==typeof n&&(n=[[t.i,n,""]]),n.locals&&(t.exports=n.locals);r("rjj0")("f3e2 {snip}
// /js/app.js

The minified code shows:

{snip} Markers()},resetMap:function(t){t&&(google.maps.event.trigger(,"resize"),t.hasMarkers()&&t.fitMarkers())},roomUrl:function(t,e){var r=t {snip}

I have installed sentry through docker. I’ve read it is recommended to upload the javascript files and sourcemaps so i did this:

sentry-cli releases files 0.3 upload-sourcemaps ./public/js --url-prefix ‘~/js/’ --rewrite

The artifacts are uploaded and I am receiving events for my release version. I am not seeing any errors though within my events, signaling that something is wrong with my sourecmaps. I assume the utf-8 encoding on my files is fine and I won’t have to deal with incorrect headers since I uploaded the files locally.

I have validated the sourcemaps, the sourceMappingUrl’s are available and everything seems fine. Sentry works fine but the sourcemapping is not working.

I am building my files with Webpack, for production they are built with ‘cheap-source-map’:

I have tried uploading artifacts with the full --url-prefix to our cdn domain but this does not work either.

Our javascript files are being cached busted with a querystring but I guess this should not matter since the mappings do not need this:


Is there anything else I can do to debug this?


I have gone into my UI and visited the artifacts tab there to check out my files. When I run this:

curl -I -k https://<domain>/api/0/projects/sentry/vue/releases/0.3/files/40

I am seeing this Content-Type header:

Content-Type: application/json

Could this be the problem?

According to this article the Content-Type header is a pretty big deal:

I have check my sourcemaps by checking the filetype locally:

file -bi

This is the sourcemap that has been built by webpack, which I upload as artifact. This commands returns:

text/plain; charset=utf-8