Why i cannot expose sentry service over ELB

I’ve been trying to expose sentry weeks from now and the only way it worked for me was when i exposed it over nginx ingress on root path (as it cannot be exposed over subpath) now i’m trying to get rid of ingress and expose the sentry service as an internal load balancer by adding this annotation to the service.yaml :

service.beta.kubernetes.io/aws-load-balancer-internal: "true"

But the url keeps refreching and nothing happens after.
Please tell if there is a solution or not because i wasted a lot of time on it

Have you set the system.url-prefix properly?

Where to set it, in config.yml ??

Yup. See here: https://develop.sentry.dev/config/#general

I tried with this command inside sentry-web container but i still have the same problem:
sentry config set system.url-prefix internal-xxxxxx.eu-west-1.elb.amazonaws.com

You need to set this in the config and restart your server.

I already tried that and restarted sentry-web, here is my config.yml :

# While a lot of configuration in Sentry can be changed via the UI, for all
# new-style config (as of 8.0) you can also declare values here in this file
# to enforce defaults or to ensure they cannot be changed via the UI. For more
# information see the Sentry documentation.

###############
# Mail Server #
###############

# mail.backend: 'smtp'  # Use dummy if you want to disable email entirely
# mail.host: 'localhost'
# mail.port: 25
# mail.username: ''
# mail.password: ''
# mail.use-tls: false
# The email address to send on behalf of
# mail.from: 'root@localhost'

# If you'd like to configure email replies, enable this.
# mail.enable-replies: false

# When email-replies are enabled, this value is used in the Reply-To header
# mail.reply-hostname: ''

# If you're using mailgun for inbound mail, set your API key and configure a
# route to forward to /api/hooks/mailgun/inbound/
# mail.mailgun-api-key: ''

###################
# System Settings #
###################

# If this file ever becomes compromised, it's important to regenerate your a new key
# Changing this value will result in all current sessions being invalidated.
# A new key can be generated with `$ sentry config generate-secret-key`
# system.secret-key: 'changeme'

# The ``redis.clusters`` setting is used, unsurprisingly, to configure Redis
# clusters. These clusters can be then referred to by name when configuring
# backends such as the cache, digests, or TSDB backend.
# redis.clusters:
#   default:
#     hosts:
#       0:
#         host: 127.0.0.1
#         port: 6379
system.url-prefix: " internal-xxxxxx.eu-west-1.elb.amazonaws.com"

This needs to be a full-blown URL, complete with the protocol (http:// or https://) and without a space at the beginning or end.