Wrong DSN format


#1

Hello guys,

I’m having doubt on why the dsn generated by my Sentry (on-premise) is like this:

://bd38ea654d374917b4d5a70c699c425:5df877f466b54eac84b8398df0eec9a@/221

I think the right form should be:

https://bd38ea654d374917b4d5a70c699c425:5df877f466b54eac84b8398df0eec9a@mysentry.com/221

So, does anybody know how to fix it? Or is there anything with my configuration?

Thanks!


#2

T̶h̶a̶t̶ ̶i̶s̶ ̶p̶e̶r̶f̶e̶c̶t̶l̶y̶ ̶n̶o̶r̶m̶a̶l̶.̶

Read answer below.

This stackoverflow link describes it in some detail and also links to the RFC source. Both are worth a read. :smiley:


#3

This is not normal. It’s not just a protocol relative URL. If you look closer, it’s missing the hostname as well.

This is due to missing the system.url-prefix setting. We use this to construct the DSN, but when it’s missing, you’ll get a value like you showed.


#4

Heads up this can happen with the Docker install as the default caching backend is in-memory (and per process/thread). We probably should fix the defaults here.