AUTH Options Not Listed


#1

We are running Sentry On-Premise w/Docker:

  • Sentry v. 9.0.0
  • Docker version 18.06.1-ce, build e68fc7a

Overall service is working as expected. However, we are not seeing any AUTH options listed: /settings/my-org-name/auth/. I have added the following to our sentry.conf.py.:

# SSO ON our OFF
SENTRY_FEATURES['organizations:sso'] = True
SENTRY_FEATURES['organizations:sso-saml2'] = True
SENTRY_FEATURES['organizations:sso-rippling'] = True

Ran the following, to update our docker-build:

docker-compose build
docker-compose run --rm web upgrade
docker-compose up -d

Upon web UI refresh, we still are not seeing any auth options listed. Has anyone experienced this issue? Not sure if there is some other setting I need to enabled to achieve SSO.

Thanks in advance,
-Beau


#2

You need to also install the various plugins. e.g. sentry-auth-github on GitHub


#3

Thanks for getting back with me.

We are wanting to integrate with Okta SSO. Is there a specific plugin that needs to be installed? I have installed the generic SAML2 plugin found here: https://github.com/getsentry/sentry-auth-saml2 — Also read through this tutorial: https://saml-doc.okta.com/SAML_Docs/How-to-Configure-SAML-2.0-for-Sentry.html, which did not provide actual Sentry / Okta installation details.

Still not seeing anything listed under our auth settings. Please advise.

Thanks,
-Beau


#4

I also installed the Github Auth plugin: https://github.com/getsentry/sentry-auth-github. Created an OAUTH App within GH under our org, updated our sentry.conf.py with the GITHUB_APP_ID & GITHUB_API_SECRET. Rebuilt using the following:

docker-compose build 
docker-compose run --rm web upgrade
docker-compose up -d

Also, ran sentry upgrade – still do not see any Auth Apps listed within our On-premise Sentry setup. What further action do I need to do inorder to integrate SSO?


#5

I thought that the Sentry 9.0.0 docker image has the sentry_plugins installed that has all the auths…


#6

Update: found that the Sentry:9.0 image needs to have the system packages added to get SAML working:

libxmlsec1-dev
pkg-config

#7

Thanks for the follow up, I will give this a try.

-Beau