Cannot factory reset Sentry

After getting myself into a state with broken OAuth that I can’t remove, I’ve been trying to just wipe my Sentry instance and start again from scratch. I run these commands in my onpremise repo:

git clean -xf
docker-compose down -v

However, the install script does not ask me the setup questions, and after running docker-compose up -d I still get my oauth redirect at login.

It seems Sentry is storing some state outside of the onpremise folder, and outside of a Docker volume. Where is it? How do I rebuild my Sentry instance from scratch?

Yes, since we use Docker, we store the data in Docker volumes. You can find more information here:

I thought docker-compose down -v would remove volumes, too.

It only removes “local” volumes. We define certain volumes as external for easier backups and prevent accidental data loss (there’s also a legacy aspect).

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.