Sentry and Docker volumes

Our Sentry on-premise server went down for some reason I could not determine. I apologise for the lack of details about this but I still don’t understand fully how Sentry and all it’s dependencies work, including Docker.

After the server failure, I tried to run the container again using docker-compose up -d. The command also failed, so I thought it was a good opportunity to update Sentry version. I ran the install script, which updated things, created new images, etc.

The problem is that it appears to have created new Docker volumes, so we lost all of our setup, such as user details, project config, etc.

I did not delete any volumes or containers (except the ones that could have been deleted by the install script itself).

Here are the docker volumes in the server (we don’t use Docker for anything else in this machine, so they should all be related to Sentry):

DRIVER              VOLUME NAME
local               592f952580eb343d612b6baf3a9986fe9df513606a1c8376932d1656a18eea76
local               603b4c73aae05fca068e840a2c1a3471d410deb40656285ce929353dec3e4c88
local               7102cc90afcfeaa2f96af44133f09a1ef4a1a6ac3997da79acc63e52e8b8ff71
local               b4ac6715d96e732c2642e2df964a5bdd49f1bf991acbcfa6ef4de9da864f52aa
local               sentry-clickhouse
local               sentry-data
local               sentry-kafka
local               sentry-postgres
local               sentry-redis
local               sentry-symbolicator
local               sentry-zookeeper
local               sentry_onpremise_sentry-clickhouse-log
local               sentry_onpremise_sentry-kafka-log
local               sentry_onpremise_sentry-secrets
local               sentry_onpremise_sentry-smtp
local               sentry_onpremise_sentry-smtp-log
local               sentry_onpremise_sentry-zookeeper-log

My question is, how can I try and recover our data? By using docker volume inspect on these, the creation date is nearly the same, so it seems they have been all created by the install script.

I would appreciate any help you can provide on this matter.

We’d need to see the install logs (which are automatically created and stored by the install script) to provide you with more information.

Based on what you described, your old installation did not persist data through volumes, which would mean you’ve lost them for good. As the install script is designed to preserve data from older installations.

1 Like

Thanks, I’ll examine the logs.
Are these the volumes I should be backing up?

local               sentry-clickhouse
local               sentry-data
local               sentry-kafka
local               sentry-postgres
local               sentry-redis
local               sentry-symbolicator
local               sentry-zookeeper

The log starts with:

Checking minimum requirements...
Removing network onpremise_default
Network onpremise_default not found.
Removing network sentry_onpremise_default
Network sentry_onpremise_default not found.

Creating volumes for persistent storage...
Created sentry-data.
Created sentry-postgres.
Created sentry-redis.
Created sentry-zookeeper.
Created sentry-kafka.
Created sentry-clickhouse.
Created sentry-symbolicator.

sentry/sentry.conf.py already exists, skipped creation.
sentry/config.yml already exists, skipped creation.
sentry/requirements.txt already exists, skipped creation.

Fetching and updating Docker images...

...

It does look like it created new volumes there.

It would say that but it doesn’t necessarily mean they were not there before. Were you able to make any progress?