How to load the config.yml file?

I have set up a on-premise installation with a docker-compose file. Now I have added a config.yml file after I have set everything up. So I have everything up and running already.

I tried using:

docker-compose down

and:

docker-compose up -d

But it will not read new changes from the config.yml file(my mail server settings). How can I load this configuration file? Do I need to rebuild or something? Or is there an easier way?

I simply need to get the email server settings supplied.

I have the same issue. I also activated the mail configurations and add my settings but nothing happen. Also when I directly change this stuff in the sentry.conf.py nothing happens after a restart.

I think you might be hitting this issue. You should be able to change the mail settings by changing the default values in sentry.conf.py or by setting the corresponding environment variables.

I another solution I have used is to replace the sentry.conf.py from the onpremise repo with one generated by sentry init. This makes config.yml work correctly but the downside is that it removes the possibility of configuring Sentry via environment variables, but I wasn’t using that feature anyway.

In which container did you execute sentry init and make the configurations? In sentry_base

I don’t recall but I don’t think it matters – they are all identical. You can also find the template for the default config on Github.

I found the problem. Everything works fine. For the first time I do not set the email data in config.yml. After I deleting all images and containers and generate the images again, it works. Thank you

@christian, could you please be more specific about the commands you’ve executed? I did what you wrote, yet Sentry’s UI still shows the default settings and they are all read only.

  1. First I stopped the containers and made sure they were stopped with docker ps
  2. Then I deleted the images with docker rm sentry_web_1 and docker rm sentry_web_run_1
  3. Then I made sure my config file has the data I want and ran make build
  4. Then I ran docker-compose up

Sentry started correctly, but the new settings were not there. What step am I missing?

@ralienpp, Hi.
I did not execute step 3. After deleting all container and images I update the config file and run docker-compose up

can you please explain this solution for the python installation?

Only reboot the system its worked for me.